Quantcast

ssh hangs w/jumbo frames (MTU=9000)

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

ssh hangs w/jumbo frames (MTU=9000)

Robert La Ferla
I have been experiencing ssh hangs with my client hosts that are  
using jumbo frames.  I have a LAN with all Gigabit switches  
(Netgear), CAT 5e or greater cabling.  This happened from a Mac  
client (gigabit) and also a Fedora client (Intel gigabit card.)  
There were no error or warning messages.  I even ran sshd using the  
debug switch.  When I dropped the MTU to 1500 on the clients (but not  
the server), they all worked again.  What could be the problem?


--
This message has been scanned for viruses and
dangerous content by MailScanner, and is
believed to be clean.


Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: ssh hangs w/jumbo frames (MTU=9000)

Robert La Ferla
I should add that the problem manifests itself when I ssh into the  
server and "cat" a large text file or such.

On Dec 19, 2006, at 11:47 AM, Robert La Ferla wrote:

> I have been experiencing ssh hangs with my client hosts that are  
> using jumbo frames.  I have a LAN with all Gigabit switches  
> (Netgear), CAT 5e or greater cabling.  This happened from a Mac  
> client (gigabit) and also a Fedora client (Intel gigabit card.)  
> There were no error or warning messages.  I even ran sshd using the  
> debug switch.  When I dropped the MTU to 1500 on the clients (but  
> not the server), they all worked again.  What could be the problem?


--
This message has been scanned for viruses and
dangerous content by MailScanner, and is
believed to be clean.


Loading...